USN-3111-1: Firefox vulnerabilities

Ubuntu Security Notice USN-3111-1

27th October, 2016

firefox vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 16.10
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

Several security issues were fixed in Firefox.

Software description

  • firefox – Mozilla Open Source web browser

Details

A use-after-free was discovered in service workers. If a user were tricked
in to opening a specially crafted website, an attacker could potentially
exploit this to cause a denial of service via program crash, or execute
arbitrary code. (CVE-2016-5287)

It was discovered that web content could access information in the HTTP
cache in some circumstances. An attacker could potentially exploit this
to obtain sensitive information. (CVE-2016-5288)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 16.10:
firefox 49.0.2+build2-0ubuntu0.16.10.2
Ubuntu 16.04 LTS:
firefox 49.0.2+build2-0ubuntu0.16.04.2
Ubuntu 14.04 LTS:
firefox 49.0.2+build2-0ubuntu0.14.04.1
Ubuntu 12.04 LTS:
firefox 49.0.2+build2-0ubuntu0.12.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart Firefox to make
all the necessary changes.

References

CVE-2016-5287, CVE-2016-5288

Let’s block ads! (Why?)

Ubuntu Security Notices

Popular Posts
  • No Popular Post Available