USN-3114-1: nginx vulnerability

Ubuntu Security Notice USN-3114-1

25th October, 2016

nginx vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 16.10
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

The system could be made to run programs as an administrator.

Software description

  • nginx – small, powerful, scalable web/proxy server

Details

Dawid Golunski discovered that the nginx package incorrectly handled log
file permissions. A remote attacker could possibly use this issue to obtain
root privileges.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 16.10:
nginx-extras 1.10.1-0ubuntu1.1
nginx-full 1.10.1-0ubuntu1.1
nginx-common 1.10.1-0ubuntu1.1
nginx-light 1.10.1-0ubuntu1.1
nginx-core 1.10.1-0ubuntu1.1
Ubuntu 16.04 LTS:
nginx-extras 1.10.0-0ubuntu0.16.04.3
nginx-full 1.10.0-0ubuntu0.16.04.3
nginx-common 1.10.0-0ubuntu0.16.04.3
nginx-light 1.10.0-0ubuntu0.16.04.3
nginx-core 1.10.0-0ubuntu0.16.04.3
Ubuntu 14.04 LTS:
nginx-extras 1.4.6-1ubuntu3.6
nginx-full 1.4.6-1ubuntu3.6
nginx-common 1.4.6-1ubuntu3.6
nginx-light 1.4.6-1ubuntu3.6
nginx-core 1.4.6-1ubuntu3.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2016-1247

Let’s block ads! (Why?)

Ubuntu Security Notices

Popular Posts
  • No Popular Post Available